Using videos in the new update crashes Principle

Have you searched the Docs and Knowledge base? Yup
Principle Version: 6.11
macOS Version: 11.6
Description of what you need help with:
Principle keeps showing the spinning color fan when I open the file. I have videos inside the prototype which played fine before the update.
Any suggestions?

Steps to reproduce the behavior:

  1. Just open the prd and do something in the timeline and see it stall out.

I am wondering if it is the size of the videos I have in the prototpye.

.prd file link (we really need this to fix almost any problem):

I’m not seeing a stall or crash with that file. I opened it, clicked the first transition and then dragged a keyframe. Is that what you’re doing?

Are you sure you’re on 6.11 and not 6.10? 6.11 fixed an issue with video.

Yeah I am on Version 6.11 (6013)

I happens when I click on the second transition “bottom timer bar tap” and scrub the timeline, then principle hangs with the spinning fan and I have to force quit.

I am on an M1 mac running Big Sur 11.6 (20G165)

@Daniel It’s still crashing. I made a completely different file, added some animation and a video to it and it hangs. Any ideas? Is there a way to downgrade to the prior version until this gets fixed? I have a critical update I need to make to a prototype I made.

Everything is fine until you start messing with the animation timeline and then crash. It seems like if you don’t touch the animation, you’ll be fine.

@Daniel I see in License Manager FAQ that says I can download an older version but when I put in my license I only see an option to download 6.11.

Where do I go to revert to the prior version?

@Daniel Any word on this? Is there a better way to get in touch with you? Hanging on a limb here.

Here’s a link to get Principle 6.10

@wtrsld After looking into it a bit more, it seems it’s a bug with macOS 11.6 - it happens in 6.10 too.

I’m working on a workaround. hang tight.

@wtrsld Ok I think I’ve got it sorted. Try this out:

Ok tried it out. I used the previously shared prd file and clicked on animation lines, then I scrub those lines to watch in the preview. The app hangs for about 8-10 sec and then the balloon goes away but the videos don’t play after that in preview.

I then opened a smaller prd that had videos that were smaller in filesize and followed the same flow as above, and the balloon has been spinning for a while now.

Do you need to know anything else?

Have you tried restarting your computer?
Could you link to a screen recording of what you’re doing in the beta version of Principle to cause the hang?

6.14 seems to clear this up. Just noticed video playback controls in the media picker of the asset.

Weirdly though there is no audio when I record the prototype and save as a video.

Any thoughts?

Principle doesn’t include audio when exporting video recordings.