Impossible to import file with images from Figma

Have you searched the Docs and Knowledge base?
Principle Version: Version 6.15 (6017)
macOS Version: 11.4 (20F71)
Description of what you need help with:
Principle doesn’t let me import any file from Figma

Steps to reproduce the behavior:

  1. Select art-board from Figma
  2. Click import on Principle
  3. Error message

.prd file link (we really need this to fix almost any problem):
Screenshots:

1 Like

Please share a link to a figma document with the issue so that I can look into this

Unfortunately I can’t share internal Figma files. Although this happens with any of them, even the simpler ones.

The message says either ‘Couldn’t download images’ or ‘Couldn’t read document’ () See attached.

Thansk

Screenshot 2022-03-29 at 09.30.28

1 Like

If it happens with any of your figma files, then it should be easy to create a sample figma file that you can send me a link to. I really need a figma file with the issue in order to fix it.

Hi Daniel,

I’ve got the same problem today when i tried to import a figma file into Principle(Version 6.15 (6017)) .

1 Like

Hi Daniel,
I have two different computers and two licenses. Both have the same problem. I can’t import anything from Figma for the last couple of days. Neither a simple file nor a complex one.
Figma 107.1
Principle App 6.15 (6017)

Please Help.

@KatyaVern Have you tried importing this again recently? I was able to import it successfully just now. Sometimes figma’s servers get overwhelmed and trying again later works.

@laguta Could you post a link to a figma document that isn’t importing?

1 Like

Yes, but it has failed to import again. And I tried to import older files that I’d already animated in Principle before, but this time the app can’t import them. I constantly get the same message that I attached in my previous post.
Thank you for your help.

1 Like

@Daniel Hi Daniel
This problem is steel actual.
I can’t import any file from Figma to Prnpl (6.15)
You can try to import this artboard – the link

Hi Katya,
I have the same problem with importing from Figma as you. Do you still have this problem?

@sherstnevaya @KatyaVern @laguta

What countries are you in? I’m wondering if it’s a location-specific thing

1 Like

Hi Daniel. I am in Russia

1 Like

@Daniel Hi, Daniel
I’m in Russia too.
But I suppose, the issue was on the Figma side. Yesterday (April 5th), I had installed Figma update and export from Figma was sucсessful.
Or maybe it was coincidence :slight_smile:

Hi Sherstnevaya,

Yes, i do.

hi Daniel,

I reside in Russia. For now the only workaround I’ve found is to export multiple png files from figma and manually insert them into principle.

@KatyaVern @sherstnevaya @laguta Ok, I suspect it’s an issue on figma’s end related to your location.

If the recent figma update doesn’t fix it, please try this version of principle - it includes logging information to help me see what part of figma is failing. https://principleformac.com/download/Principle_6_16_beta_2.zip Import the problematic file and then send support@principleformac.com the import log text file