Importing Figma into Principle

Have you searched the Docs and Knowledge base? Yes, I have
Principle Version: Version 6.15 (6017)
macOS Version: MacOS Monterey 12.0.1 (21A559)
Description of what you need help with: I am having issues importing files from Figma to Principle. Is anyone else facing the same issue? Every time I try to import a frame from Figma into Principle, there are error messages saying, “Couldn’t read document”

Steps to reproduce the behavior:

  1. Open Principle
  2. Import from Figma
  3. Selects frame in Figma and comes back into Principle to click on import.

I have tried using different Figma accounts and the same problem persists. I have also tried copying the frame into a new Figma file and tried to import for a different Figma file. I didn’t work either. I tried “Detaching Instances” of all the components in the frame cause I suspected that the problems was with the components and it didn’t work too. Next, I tried importing individual frames from the website frame as I hypothesized that the issue might be that there is too many layers in the website frame to be imported properly and that didn’t work as well. I can’t seem to figure out what the issue is after trying out all these. Could the issue be with Figma?

.prd file link (we really need this to fix almost any problem):


I have the same issue importing any file with images, big or small.

1 Like

I emailed Figma about it but the respond wasn’t really helpful. But I found a fix around it.

I think the issue is that Principle can’t handle the import if you’re importing many layers at a go. I had probably 300+ layers in my Figma frame to be imported. Also, Principle has issues importing layers with opacity switched on. So what I did was I only importing areas that I needed to animate and the rest, I imported them as PNG in sections and then piece them back within Principle.

Not the most ideal cause sometimes the PNG import is not 100% accurate but at least it works. See if this works for you!

1 Like

@kyonyhk Principle can easily handle 300+ layers. We’ve seen this in the past and it was because figma was sending Principle bad data. Could you please share a link to a figma document that has the issue? If it’s private - feel free to mail it to and you can even delete all but the problematic artboards.