Import Failed (Sketch V68)

So for a some time, I have problem with the importing screens from Sketch.
Before creating new topic, I tried to Google the problem. I tried the search option here. Didn’t fond the solution. I saw where someone suggested sketch file should be local, it already is, still doesn’t work.

So I am going to paste here the log issue. And btw, standard importing steps, Selecting screens in the Sketch app, opening Principle, Import from figma, and import selected screens.

Here is the log

Email both this file and the Sketch file to
versions:sk 68 -> pr 5.10
os:Version 10.15.5 (Build 19F96)
Script: /Applications/

ReferenceError: Can’t find variable: MSImmutableLayerAncestry
at export_layer (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:765:44)
at process_layer (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:492:40)
at process_layer (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:521:52)
at artboardToMetaData (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:149:35)
at flatMap (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:842:39)
at exportDirect (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:156:34)
at onRun (/Users/merzukspahic/Library/Application Support/com.bohemiancoding.sketch3/Plugins/Untitled.sketchplugin:871:13)

So at the moment, I have Sketch V68. Could that be the problem, that Principle is incompatible with the newer Sketch versions than 66?

I would really really appreciate the help.

check for updates to get Principle 5.11

Hi Daniel,

I am already on 5.12 version, am I supposed to downgrade to 5.11?

That import failure log is from Principle 5.10. if you’re on 5.12 now, try importing again.