Can't Import from Sketch

#1

Each time I try to import from Sketch to Principle no matter how big the file is or how many screenshots Principle just freezes out. You can see in the video

Principle Version: Principle 5.8
macOS Version: MacOS Mojave 10.14.5
Sketch Version: Sketch 55
Description of what you need help with:

Video: https://www.dropbox.com/s/38hfp3waaaww1di/Principle%20Crash.mov?dl=0

0 Likes

#2

Are both apps up to date? (Principle and Sketch)

Have you tried saving your Sketch document before clicking import?

Does it happen if you select only 1 artboard?

Does it happen with a fresh new document too?

Sometimes trying different things will help you identify the source of the issue, if it works with a new document, it may be your file is corrupt in someway…

0 Likes

#3

I have tried everything you said. Also all of the apps are up to date, and I have tried with just the artboards I need to sync them to Principle. Still getting this error

0 Likes

#4
  1. restart your computer
  2. then try importing a new sketch file with a single artboard that contains a single rectangle. This will isolate if the problem is specific to the document or something else.
  3. if the previous thing succeeded, you can try importing your file again.
  4. If that still doesn’t work, send the sketch file to support for investigation: http://principleformac.com/contact.html
0 Likes